软件升级之痛 | firefox版本限制之傻

作者:半瓶墨水   链接:http://www.2maomao.com/blog/painful-auto-update-and-firefox/

不知道什么时候开始,所有的软件都开始能够自动更新了
在这之前,安装软件都要卸载、重启、重装,有时候还会引起一堆堆的问题
自动更新多方便啊,这是我曾经很喜欢的一个特性

但是近一年来,我安装好软件以后,第一件事情都是“禁止自动更新”(杀毒软件除外)
不是自动更新这个想法不好了,而是多数自动更新的软件做法太差,我称之为“自动更新综合症”

“自动更新综合症”常见症状列举
1. 干掉用户数据
1.a 无视用户的自定义设置,重新开始配置吧,老大!
1.b 干掉打开过的文件列表,你辛苦收藏的东东再也找不到
1.c 重新登录吧,让这个傻x软件重新开始记住每个帐号

2. 随意增加新功能
2.a 本来只有两个核心功能的软件,升级完变成18个,上个版本中的功能都还在,但是就是找不到
2.b 一排子按钮,好好的软件,更新了一次,哇塞,这还是原来那个xxx吗?
2.c 好不容易找到了熟悉的功能,突然间发现,这丫的行为方式好陌生~~~

3. 强制更新
3.a 强制更新以一种流氓行为!
3.b 老大你看,软件我给你下好了,*请您*重新启动软件就自动更新。请…请您…请您大爷的!
  语气再谦虚,也掩饰不了流氓行为的本质
3.c 或者软件打开以后,弹出一个对话框,一个按钮叫做”更新”,一个叫做”关闭”
3.d 有一天打开软件,丫说更新完啦我要重启啦,还有四个小时就重启,开始倒计时~~~
  我在工作哎,如果不是要死人的事情,能不能别这么烦啊

4. 拙劣的更新手法
4.a 最拙劣的更新手法,就是写个下载器,下载一个全新的安装程序,然后安装
  F*ck,直接拿快车下载多快,你丫的还不给断点续传
4.b 更拙劣的要求你先卸载、重启、安装、然后再重启、日!
4.c 最拙劣的,更新会失败,用户数据全部丢失不说,你还得跑到某个目录下删掉几个神秘的文件,然后再开重装

好了,发完牢骚,回头看firefox的问题,Firefox我一直是禁止更新的
但是最近这两天撞鬼了,我的几台机器上的Firefox都自动升级成3.0.4了
直接后果就是总共花了接近一个小时搞定插件升级、配置等一系列问题
然后,还有几个重要的插件不能使用,因为没有最新版。

Firefox的插件版本管理都是这样胡来的,每个插件都会标上适用范围
不是用的Firefox不让装,已经装上的不给用,而且普通用户“完全没有办法”,只能等插件作者更新
但是哪个插件作者整天盯着Firefox的更新,然后发布新版本呢?累不累啊
软件首先要考虑好用,然后再考虑安全吧

据我自己试验,多数时候Firefox更新后,插件还是能用的,只是版本号设置的问题
其实Firefox只需要问一句:这个插件没有明确表示支持当前的Firefox版本,您要安装/启用吗?
另外,firefox设计的时候能不能够有个标准的东西,在一个大版本内不变呢?这样大家些插件版本都可以直接按大版本来了。

我反正后来找到一个禁止插件版本限制的方法,顺手检查了以便自动更新的设置,我算是怕了

2 条评论 发表在“软件升级之痛 | firefox版本限制之傻”上

  1. guotie说道:

    没这么夸张吧?

  2. 淡定说道:

    不就是插件么,加个参数就好啦。
    extensions.checkCompatibility :k 布尔 ,值为 false

留下回复